Issues with search history
Incident Report for FetLife
Resolved
We have successfully recovered the lost search history.
Posted Jan 22, 2025 - 12:47 PST
Investigating
We've identified issues with members having lost their search history and are recovering it.
Posted Jan 22, 2025 - 12:02 PST
This incident affected: Website.