Emails are delayed or not being delivered
Incident Report for FetLife
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 09:41 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2024 - 09:25 PDT
Update
Most of the emails we are trying to send you, like for email verification or a password reset, are not being delivered right now.

We are very sorry and are working hard on fixing this issue.
Posted Oct 17, 2024 - 09:13 PDT
Investigating
We are currently investigating this issue.
Posted Oct 17, 2024 - 08:56 PDT
This incident affected: Website.