Email Notification Issues
Incident Report for FetLife
Resolved
This incident has been resolved and any bounce marks generated on Microsoft domains should be removed now. If you are still having email issues please do not hesitate to contact support@fetlife.com
Posted Apr 08, 2021 - 13:29 PDT
Update
Clarifying previous update: A fix has been implemented and we are monitoring and slowing enabling more email to be sent to Microsoft domains.
Posted Feb 23, 2021 - 12:56 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2021 - 05:41 PST
Identified
We have identified an issue with some email providers (namely Microsoft based properties such as Hotmail.com and Outlook.com) and are working with those providers to resolve the issue.
Posted Jan 26, 2021 - 15:55 PST