Signup & Password Reset Emails are Delayed
Incident Report for FetLife
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 13:22 PDT
Monitoring
Emails are being sent immediately again.

Unfortunately for members who reset their password or tried to signup in the past 3 hours, the delayed emails will have expired and won't work anymore. So those members will need to restart the signup or password reset flow.
Posted Jul 28, 2022 - 13:09 PDT
Identified
Related to AWS outage which is impacting our email delivery system provider. We're monitoring the situation and waiting for them to fix the issue. Emails will eventually arrive, but heavily delayed.
Posted Jul 28, 2022 - 12:00 PDT