FetLife - Some emails to Apple iCloud Mail are delayed – Incident details
All systems operational
The official FetLife status page
Some emails to Apple iCloud Mail are delayed
Resolved
Degraded performance
Started about 2 months agoLasted 8 days
Affected
Email notifications
Degraded performance from 10:45 PM to 7:25 PM
Updates
Resolved
Resolved
This incident has been resolved.
Update
Update
We have applied a fix that has sent some of the delayed emails. This could have resulted in you getting email notifications that are outdated. Sorry about that!
Update
Update
We have applied a fix that has sent some of the delayed emails. This could have resulted in you getting email notifications that are outdated. Sorry about that!
Identified
Identified
We are continuing to work on a fix for this incident.