FetLife - Some notification emails are delayed – Incident details

Email notifications experiencing degraded performance

The official FetLife status page

Some notification emails are delayed

Identified
Degraded performance
Started 3 days ago

Affected

Email notifications

Degraded performance from 3:00 PM to 12:00 AM

Updates
  • Identified
    Identified

    We have applied a fix that has sent some of the delayed emails. This could have resulted in you getting email notifications that are outdated. Sorry about that!

  • Investigating
    Investigating
    We are currently investigating this incident.