FetLife - Errors on payments – Incident details
Report an issue
Get updates
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
Report an issue
Get updates
All systems operational
The official FetLife status page
Errors on payments
Resolved
Partial outage
Started 2 days ago
Lasted about 2 hours
Updates
Resolved
February 04, 2026 at 7:47 AM
Resolved
February 04, 2026 at 7:47 AM
This incident has been resolved.
Identified
February 04, 2026 at 6:18 AM
Identified
February 04, 2026 at 6:18 AM
The issue has been identified.
Investigating
February 04, 2026 at 5:29 AM
Investigating
February 04, 2026 at 5:29 AM
We are currently investigating this incident.