FetLife - Emails to Apple iCloud Mail are delayed – Incident details
Report an issue
Get updates
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
Report an issue
Get updates
All systems operational
The official FetLife status page
Emails to Apple iCloud Mail are delayed
Resolved
Degraded performance
Started 4 days ago
Lasted about 12 hours
Affected
Email notifications
Degraded performance from 8:40 PM to 8:30 AM
Updates
Resolved
March 05, 2026 at 8:30 AM
Resolved
March 05, 2026 at 8:30 AM
This incident has been resolved.
Investigating
March 04, 2026 at 8:40 PM
Investigating
March 04, 2026 at 8:40 PM
We are currently investigating this incident.