FetLife - Feed is delayed – Incident details
Report an issue
Get updates
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
Report an issue
Get updates
All systems operational
The official FetLife status page
Feed is delayed
Resolved
Degraded performance
Started 6 days ago
Lasted about 10 hours
Affected
Website
Partial outage from 1:26 PM to 11:20 PM
Updates
Resolved
February 22, 2026 at 11:20 PM
Resolved
February 22, 2026 at 11:20 PM
This incident has been resolved.
Update
February 22, 2026 at 5:27 PM
Update
February 22, 2026 at 5:27 PM
Some feed updates may still be delayed
Monitoring
February 22, 2026 at 4:30 PM
Monitoring
February 22, 2026 at 4:30 PM
We implemented a fix and are currently monitoring the result.
Identified
February 22, 2026 at 2:12 PM
Identified
February 22, 2026 at 2:12 PM
We are continuing to work on a fix for this incident.
Investigating
February 22, 2026 at 1:26 PM
Investigating
February 22, 2026 at 1:26 PM
We are currently investigating this incident.