FetLife - Emails to Apple iCloud Mail are not delivered or delayed – Incident details

Email notifications experiencing partial outage

Emails to Apple iCloud Mail are not delivered or delayed

Identified
Partial outage
Started 1 day ago

Affected

Email notifications

Partial outage from 5:15 PM to 12:00 AM

Updates
  • Update
    Update

    We have stopped sending group posts and conversation response emails while trying to make the all other types of emails to be delivered again.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.