FetLife - Issue with resetting password – Incident details

Issue with resetting password

Resolved
Operational
Started 4 months agoLasted 3 days

Affected

Website

Operational from 5:22 PM to 7:51 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this issue.