FetLife - Site is down – Incident details
Report an issue
Get updates
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
Report an issue
Get updates
All systems operational
The official FetLife status page
Site is down
Resolved
Major outage
Started 1 day ago
Lasted 3 minutes
Updates
Resolved
February 09, 2026 at 10:29 AM
Resolved
February 09, 2026 at 10:29 AM
This incident has been resolved.
Investigating
February 09, 2026 at 10:26 AM
Investigating
February 09, 2026 at 10:26 AM
We are currently investigating this incident.