Scheduled for April 15, 2025 at 8:00 AM – 8:18 AM
Affects
Email notifications
Under maintenance from 8:00 AM to 8:18 AM
Website
Under maintenance from 8:00 AM to 8:18 AM
Completed
April 15, 2025 at 8:18 AMCompleted
April 15, 2025 at 8:18 AMAll done, thank you for your patience!
Update
April 15, 2025 at 8:10 AMIn progress
April 15, 2025 at 8:10 AMWe have completed the main part of the maintenance and are performing the verifications now.
The site may be slow for a while, sorry for that!
In progress
April 15, 2025 at 8:00 AMIn progress
April 15, 2025 at 8:00 AMMaintenance is now in progress
Planned
April 15, 2025 at 8:00 AMPlanned
April 15, 2025 at 8:00 AMWe will be undergoing scheduled database maintenance during this time. This means that the site may not be available at all, work slowly or that some pages or actions may temporarily show errors. Sorry for disrupting your perving but it's necessary for the site's long-term health!